본문 바로가기

Algorithms/30 Days of Code

Day 13: Abstract Classes

Task 
Given a Book class and a Solution class, write a MyBook class that does the following:

  • Inherits from Book
  • Has a parameterized constructor taking these  parameters:
    1. string 
    2. string 
    3. int 
  • Implements the Book class' abstract display() method so it prints these  lines:
    1. , a space, and then the current instance's .
    2. , a space, and then the current instance's .
    3. , a space, and then the current instance's .

Note: Because these classes are being written in the same file, you must not use an access modifier (e.g.: ) when declaring MyBook or your code will not execute.

Input Format

You are not responsible for reading any input from stdin. The Solution class creates a Book object and calls the MyBook class constructor (passing it the necessary arguments). It then calls the display method on the Bookobject.

Output Format

The  method should print and label the respective , and  of the MyBook object's instance (with each value on its own line) like so:

Title: $title
Author: $author
Price: $price

Note: The  is prepended to variable names to indicate they are placeholders for variables.

Sample Input

The following input from stdin is handled by the locked stub code in your editor:

The Alchemist
Paulo Coelho
248

Sample Output

The following output is printed by your display() method:

Title: The Alchemist
Author: Paulo Coelho
Price: 248


풀이


package Day13;

abstract class Book {
String title;
String author;

Book(String title, String author) {
this.title = title;
this.author = author;
}

abstract void display();
}


package Day13;

class MyBook extends Book{

int price;

MyBook(String title, String author, int price){
super(title, author);
this.price = price;
}

void display(){
System.out.println("Title: " + title);
System.out.println("Author: " + author);
System.out.println("Price: " + price);
}
}
package Day13;

import java.util.Scanner;

public class Solution {

public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
String title = scanner.nextLine();
String author = scanner.nextLine();
int price = scanner.nextInt();
scanner.close();

Book book = new MyBook(title, author, price);
book.display();
}
}


'Algorithms > 30 Days of Code' 카테고리의 다른 글

Day 15: Linked List  (0) 2018.02.23
Day 14: Scope  (0) 2018.02.23
Day 11: 2D Arrays  (0) 2018.02.20
Day 10: Binary Numbers  (0) 2018.02.19
Day 9: Recursion  (0) 2018.02.19