본문 바로가기

Algorithms/30 Days of Code

Day 5: Loops

Task 
Given an integer, , print its first  multiples. Each multiple  (where ) should be printed on a new line in the form: n x i = result.

Input Format

A single integer, .

Constraints

Output Format

Print  lines of output; each line  (where ) contains the  of  in the form: 
n x i = result.

Sample Input

2

Sample Output

2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20


풀이


import java.io.*;

import java.util.*;

import java.text.*;

import java.math.*;

import java.util.regex.*;


public class Solution {


    public static void main(String[] args) {

        Scanner in = new Scanner(System.in);

        int n = in.nextInt();

        for (int i = 1; i <= 10; i++){

            System.out.println(n +" x " + i + " = " + n*i);

        }

    }

}

'Algorithms > 30 Days of Code' 카테고리의 다른 글

Day 7: Arrays  (0) 2018.02.19
Day 6: Let's Review  (0) 2018.02.14
Day 4: Class vs. Instance  (0) 2018.02.13
Day 3: Intro to Conditional Statements  (0) 2018.02.12
Day 2: Operators  (0) 2018.02.12